Liquid

Library to build User Interfaces in Dart with Virtual DOM.

Installation

Requirements:

  • Dart SDK 1.6 or greater

1. Create a new Dart Web Project

2. Add Liquid library in pubspec.yaml file:

dependencies:
  liquid: any

3. Install it

$ pub get

And now you are ready to use it, just import 'package:liquid/liquid.dart' and start writing your first application with Liquid library

You can start by going through our Tutorial, or read the source code from our examples.

Examples

Here are simple examples that is build with Liquid library:

TodoMVC example

TodoMVC application [Source Code](https://github.com/localvoid/todomvc-liquid), it is heavily commented and demonstrates many important features of this library.

Roadmap

  • Transformers to convert dynamic code into static (0.3.0)
  • Runtime checks in development mode to improve developer experience (0.4.0)
  • Linter/Static analyze
  • Component Stylesheets
  • Server-Side rendering

Libraries

liquid
liquid.dynamic
liquid.vdom