dart events

A simple event system for Dart based on existing implementations done in JavaScript or ActionScript3.

Available at the Dart pub

WARNING I you're on the M2 version of Dart, you'll probably get errors when importing the library because of the use of Streams However, the compatible "M2" code is commented out so it's easy to make it working

Libraries

dart_events

A simple "event" emitter for Dart inspired by the classical stuff used in JavaScript/ActionScript.