EventEmitter.dart

Build Status Coverage Status

Basic implementation of EventEmitter in Dart - a port of Node.js' EventEmitter enhanced with Dart goodness.

Installation

To install package in your system, declare it as a dependency:

dependencies:
    event_emitter: git://github.com/eps90/event-emitter.dart.git

Note: Pub package is on the way. Look below to see basic roadmap steps.

When you've got installed event_emitter, you can use it however you want:

  • as an EventEmitter class instance,
  • extend your classes with EventEmitter,
  • use EventEmitter as mixin.

To be done

  • asynchronous event handling with Futures

Libraries

dart_event_emitter

Main Event emitter library